summaryrefslogtreecommitdiffstats
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2002-05-31 02:59:47 +0000
committerAlan Modra <amodra@gmail.com>2002-05-31 02:59:47 +0000
commitcaf47ea6a36330e9a2501af480220435f8e180f6 (patch)
treec9b690d2c74e74ca0772ea08933a8cb2b47e4aca /bfd/Makefile.am
parent5bc56484431b5ddaa0b91a0f11fdcf6e7f7cb626 (diff)
downloadppe42-binutils-caf47ea6a36330e9a2501af480220435f8e180f6.tar.gz
ppe42-binutils-caf47ea6a36330e9a2501af480220435f8e180f6.zip
* Makefile.am (BFD32_BACKENDS): Add elf32-i386qnx.lo.
(BFD32_BACKENDS_CFILES): Add elf32-i386qnx.c. Run "make dep-am". * Makefile.in: Regenerate. * config.bfd: Add i[3456]86-*-nto-qnx* support. * configure.in: Add bfd_elf32_i386qnx_vec support. * configure: Regenerate. * elf-bfd.h (struct elf_backend_data): Add set_nonloadable_filepos, is_contained_by_filepos, and copy_private_bfd_data_p. * elf.c (assign_file_positions_for_segments): Call backend set_nonloadable_filepos. Fix non-K&R call to _bfd_error_handler. (IS_CONTAINED_BY_FILEPOS): Define. (INCLUDE_SECTION_IN_SEGMENT): Also test IS_CONTAINED_BY_FILEPOS. (copy_private_bfd_data): Use IS_CONTAINED_BY_FILEPOS. Typo fix. Fix non-K&R call to _bfd_error_handler. (_bfd_elf_copy_private_section_data): Use backend copy_private_bfd_data_p. * elf32-i386.c: Don't include elfxx-target.h when ELF32_I386_C_INCLUDED is defined. * elf32-i386qnx.c: New QNX elf backend file. * elfxx-target.h: Add elf_backend_set_nonloadable_filepos, elf_backend_is_contained_by_filepos, and elf_backend_do_copy_private_bfd_data. * targets.c: Add bfd_target bfd_elf32_i386qnx_vec.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 97afb454b5..5005593567 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -207,6 +207,7 @@ BFD32_BACKENDS = \
elf32-hppa.lo \
elf32-i370.lo \
elf32-i386.lo \
+ elf32-i386qnx.lo \
elf32-i860.lo \
elf32-i960.lo \
elf32-ia64.lo \
@@ -358,6 +359,7 @@ BFD32_BACKENDS_CFILES = \
elf32-hppa.c \
elf32-i370.c \
elf32-i386.c \
+ elf32-i386qnx.c \
elf32-i860.c \
elf32-i960.c \
elf32-m32r.c \
@@ -873,7 +875,7 @@ cpu-avr.lo: cpu-avr.c $(INCDIR)/filenames.h
cpu-cris.lo: cpu-cris.c $(INCDIR)/filenames.h
cpu-d10v.lo: cpu-d10v.c $(INCDIR)/filenames.h
cpu-d30v.lo: cpu-d30v.c $(INCDIR)/filenames.h
-cpu-dlx.lo: cpu-d30v.c $(INCDIR)/filenames.h
+cpu-dlx.lo: cpu-dlx.c $(INCDIR)/filenames.h
cpu-fr30.lo: cpu-fr30.c $(INCDIR)/filenames.h
cpu-h8300.lo: cpu-h8300.c $(INCDIR)/filenames.h
cpu-h8500.lo: cpu-h8500.c $(INCDIR)/filenames.h
@@ -1116,6 +1118,10 @@ elf32-i386.lo: elf32-i386.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/elf/i386.h $(INCDIR)/elf/reloc-macros.h \
elf32-target.h
+elf32-i386qnx.lo: elf32-i386qnx.c elf32-i386.c $(INCDIR)/filenames.h \
+ $(INCDIR)/bfdlink.h elf-bfd.h $(INCDIR)/elf/common.h \
+ $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/elf/i386.h \
+ $(INCDIR)/elf/reloc-macros.h elf32-target.h
elf32-i860.lo: elf32-i860.c $(INCDIR)/filenames.h elf-bfd.h \
$(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h \
$(INCDIR)/bfdlink.h $(INCDIR)/elf/i860.h $(INCDIR)/elf/reloc-macros.h \
@@ -1215,7 +1221,7 @@ elf32-v850.lo: elf32-v850.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf32-vax.lo: elf32-vax.c $(INCDIR)/filenames.h $(INCDIR)/bfdlink.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/elf/vax.h $(INCDIR)/elf/reloc-macros.h \
- $(INCDIR)/libiberty.h elf32-target.h
+ elf32-target.h
elf32-xstormy16.lo: elf32-xstormy16.c $(INCDIR)/filenames.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h $(INCDIR)/elf/xstormy16.h \
OpenPOWER on IntegriCloud