summaryrefslogtreecommitdiffstats
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorCatherine Moore <clm@redhat.com>2005-09-30 15:36:41 +0000
committerCatherine Moore <clm@redhat.com>2005-09-30 15:36:41 +0000
commit0f64bb027184ebd2d2818b12d1f57699f973fb1d (patch)
tree3b9aad3eeefc8e08b5c6edb84a15621e33f573aa /bfd/Makefile.am
parent4b7f6baa0bb2cd12d9401a6d9d5520c61c4a8c6c (diff)
downloadppe42-binutils-0f64bb027184ebd2d2818b12d1f57699f973fb1d.tar.gz
ppe42-binutils-0f64bb027184ebd2d2818b12d1f57699f973fb1d.zip
* Makefile.am: Bfin support.
* Makefile.in: Regenerated. * aclocal.m4: Regenerated. * archures.c (bfd_mach_bfin): New. (bfd_arch_bfin): New. bfd-in.h (bfd_bfin_elf32_create_embedded_relocs): New. * bfd-in2.h: Regenerated. * config.bfd: Bfin support. * configure: Regenerated. * configure.in: Bfin support. * libbfd.h: Regenerated. * reloc.c: Add BFD relocations for Bfin. * targets.c (bfd_elf32_bfin_vec): New. * cpu-bfin.c: New file. * elf32-bfin.c: New file.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index a4fcc64a6e..a3a2427441 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -58,6 +58,7 @@ ALL_MACHINES = \
cpu-arc.lo \
cpu-arm.lo \
cpu-avr.lo \
+ cpu-bfin.lo \
cpu-cr16c.lo \
cpu-cris.lo \
cpu-crx.lo \
@@ -117,6 +118,7 @@ ALL_MACHINES_CFILES = \
cpu-arc.c \
cpu-arm.c \
cpu-avr.c \
+ cpu-bfin.c \
cpu-cris.c \
cpu-cr16c.c \
cpu-crx.c \
@@ -223,6 +225,7 @@ BFD32_BACKENDS = \
elf32-arc.lo \
elf32-arm.lo \
elf32-avr.lo \
+ elf32-bfin.lo \
elf32-cr16c.lo \
elf32-cris.lo \
elf32-crx.lo \
@@ -392,6 +395,7 @@ BFD32_BACKENDS_CFILES = \
elf32-arc.c \
elf32-arm.c \
elf32-avr.c \
+ elf32-bfin.c \
elf32-cr16c.c \
elf32-cris.c \
elf32-crx.c \
@@ -962,6 +966,7 @@ cpu-arc.lo: cpu-arc.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
cpu-arm.lo: cpu-arm.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h \
$(INCDIR)/libiberty.h
cpu-avr.lo: cpu-avr.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
+cpu-bfin.lo: cpu-bfin.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
cpu-cris.lo: cpu-cris.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
cpu-cr16c.lo: cpu-cr16c.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
cpu-crx.lo: cpu-crx.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h
@@ -1208,6 +1213,10 @@ elf32-avr.lo: elf32-avr.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h \
elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
$(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h $(INCDIR)/elf/avr.h \
$(INCDIR)/elf/reloc-macros.h elf32-target.h
+elf32-bfin.lo: elf32-bfin.c $(INCDIR)/filenames.h $(INCDIR)/hashtab.h \
+ elf-bfd.h $(INCDIR)/elf/common.h $(INCDIR)/elf/internal.h \
+ $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h $(INCDIR)/elf/bfin.h \
+ $(INCDIR)/elf/reloc-macros.h elf32-target.h
elf32-cr16c.lo: elf32-cr16c.c $(INCDIR)/filenames.h \
$(INCDIR)/hashtab.h $(INCDIR)/bfdlink.h $(INCDIR)/elf/cr16c.h \
$(INCDIR)/elf/reloc-macros.h elf-bfd.h $(INCDIR)/elf/common.h \
OpenPOWER on IntegriCloud