summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2018-09-13 00:36:12 -0700
committerWilliam A. Kennington III <wak@google.com>2018-10-05 15:06:20 -0700
commit1eb97d9c3d3a35c6421d7e9831db14ba8e038d89 (patch)
tree49548ce7447546fadb948aa9d49414cf5758e604 /test/Makefile.am
parentf505fc0674d5cf14a8b1903cb894e4a171e28400 (diff)
downloadphosphor-watchdog-1eb97d9c3d3a35c6421d7e9831db14ba8e038d89.tar.gz
phosphor-watchdog-1eb97d9c3d3a35c6421d7e9831db14ba8e038d89.zip
Convert to standard CLI11 argument parser
This simplifies the argument parsing logic drastically and still provides the same error handling as before. Tested: Ran through unit test suite and manually verified that the command line functions as expected on a real BMC. Change-Id: Ic5d69adf5359f9f64f2ada17e6a8f3242ca03e25 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1c44162..bb1d048 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -4,8 +4,7 @@ AM_CPPFLAGS = -I$(top_srcdir)
TESTS = $(check_PROGRAMS)
# Build/add utest to test suite
-check_PROGRAMS = argument_test \
- watchdog_test
+check_PROGRAMS = watchdog_test
utestCPPFLAGS = $(GTEST_MAIN_CFLAGS) \
$(AM_CPPFLAGS) \
@@ -24,13 +23,8 @@ utestLDFLAGS = $(GTEST_MAIN_LIBS) \
$(PHOSPHOR_LOGGING_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS)
-argument_test_CPPFLAGS = ${utestCPPFLAGS}
-argument_test_CXXFLAGS = ${utestCXXFLAGS}
-argument_test_LDFLAGS = ${utestLDFLAGS}
-
watchdog_test_CPPFLAGS = ${utestCPPFLAGS}
watchdog_test_CXXFLAGS = ${utestCXXFLAGS}
watchdog_test_LDFLAGS = ${utestLDFLAGS}
-argument_test_SOURCES = ../argument.cpp argument_test.cpp
watchdog_test_SOURCES = ../watchdog.cpp watchdog_test.cpp
OpenPOWER on IntegriCloud