summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-09-06 11:39:22 +0530
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2017-09-13 12:54:39 +0530
commitbdb298f744cc71421f0c2e6f50254f933c6bb3cc (patch)
tree1505ad26fc8078c7fa6e0bd427d4e6f2ef9941c6 /Makefile.am
parent54309f17f35169e9f4b617b98fec43f6ac6507e1 (diff)
downloadphosphor-user-manager-bdb298f744cc71421f0c2e6f50254f933c6bb3cc.tar.gz
phosphor-user-manager-bdb298f744cc71421f0c2e6f50254f933c6bb3cc.zip
Extract crypto algorithm field and add utility functions
Password field of a user in /etc/shadow contains 3 parts: [Crypt algorithm, Salt, encrypted password] Example: A value of "1" in crypt algorithm maps to MD5 Need to use the same crypt algorithm that is already used before when the new password is to be updated. Change-Id: Ib7d8e0ad6f3bcce30f5c2be89b4e033230c07bf4 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 472dd06..aebc8a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,9 @@ phosphor_user_manager_SOURCES = \
mainapp.cpp
phosphor_user_manager_LDFLAGS = $(SDBUSPLUS_LIBS) \
- $(PHOSPHOR_DBUS_INTERFACES_LIBS)
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS) \
+ -lcrypt \
+ -lstdc++fs
phosphor_user_manager_CXXFLAGS = $(SYSTEMD_CFLAGS) \
$(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
OpenPOWER on IntegriCloud