summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2017-02-09 11:37:26 +0800
committerLei YU <mine260309@gmail.com>2017-10-15 20:15:34 +0800
commit415b964f063f81cd8ec3d1ffc3955be51de06690 (patch)
tree581108a6e5501488572f32a3645cc6ac6092b9e3 /test/Makefile.am
parentaf5abc5785535f4e059a35be60dbbd012c61facf (diff)
downloadphosphor-time-manager-415b964f063f81cd8ec3d1ffc3955be51de06690.tar.gz
phosphor-time-manager-415b964f063f81cd8ec3d1ffc3955be51de06690.zip
Add time Manager to handle property changes callback
1. Implement time::Manager who registers property change signal for time mode and owner; 2. Add PropertyChangeListner interface to handle the callback; 3. Make EpochBase to implement the interface. Change-Id: I185580ae37353e1ed82a47e4905fb22e269ac09d Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index bdd258e..b8ea41c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,8 @@ check_PROGRAMS += test
test_SOURCES = \
TestEpochBase.cpp \
TestBmcEpoch.cpp \
- TestHostEpoch.cpp
+ TestHostEpoch.cpp \
+ TestManager.cpp
test_LDADD = $(top_builddir)/libtimemanager.la
OpenPOWER on IntegriCloud