summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-07-25 05:48:58 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-07-28 06:34:50 -0500
commit20ed79e00ea163a2f24c13baa6f60a87ac268f2c (patch)
treef6c664e0119a8851a09f5d57e099552043f75d0c /configure.ac
parenteaee45522525b0b6d479cf9ac6afe4767648d258 (diff)
downloadphosphor-time-manager-20ed79e00ea163a2f24c13baa6f60a87ac268f2c.tar.gz
phosphor-time-manager-20ed79e00ea163a2f24c13baa6f60a87ac268f2c.zip
Add API to retrieve settings
Add API to retrieve all settings objects of interest to the time manager. Change-Id: I3d121c08d0156cf481a3468e6c7ca9b71f53d666 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2769644..fc0da82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,12 @@ AC_PROG_MAKE_SET
# Checks for libraries.
AC_CHECK_LIB([mapper], [mapper_get_service], ,[AC_MSG_ERROR([Could not find libmapper...openbmc/phosphor-objmgr package required])])
PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
+PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
+ AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
+PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
+ AC_MSG_ERROR(["Requires sdbusplus package."]))
+PKG_CHECK_MODULES([PHOSPHOR_LOGGING], [phosphor-logging],,\
+ AC_MSG_ERROR(["Requires phosphor-logging package."]))
# Checks for header files.
AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find systemd/sd-bus.h...systemd developement package required])])
OpenPOWER on IntegriCloud