summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNagaraju Goruganti <ngorugan@in.ibm.com>2018-04-06 13:41:01 -0500
committerNagaraju Goruganti <ngorugan@in.ibm.com>2018-05-12 04:57:37 +0000
commitcb781fe1b8750712b9f8c6e534e794d27204c5ef (patch)
tree48428765acf75b0a66eedbcdbd4ff2f40046ca1c /Makefile.am
parent41a774efacb3f3a9593aeaa971468e770d205e13 (diff)
downloadphosphor-state-manager-cb781fe1b8750712b9f8c6e534e794d27204c5ef.tar.gz
phosphor-state-manager-cb781fe1b8750712b9f8c6e534e794d27204c5ef.zip
Add Chassis POH Counter
Added 32-bit counter, which shows how many hours the system has been running. The value is a cumulative one and includes all working hours since production. If the chassis state is Powered-on, This will be incremented by one for every hour. It won't get updated when the chassis state is powered-off. Resolves openbmc/openbmc#2979 Change-Id: I18e9bb571d1a6e401b25450168249f70891be665 Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dbd84f9..5aff810 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,14 +37,14 @@ generic_cxxflags = \
generic_ldflags = \
$(SYSTEMD_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
- $(SDBUSPLUS_LIBS)
+ $(SDBUSPLUS_LIBS) \
$(PHOSPHOR_LOGGING_LIBS)
phosphor_host_state_manager_CXXFLAGS = $(generic_cxxflags)
phosphor_host_state_manager_LDFLAGS = $(generic_ldflags) -lstdc++fs
phosphor_chassis_state_manager_CXXFLAGS = $(generic_cxxflags)
-phosphor_chassis_state_manager_LDFLAGS = $(generic_ldflags)
+phosphor_chassis_state_manager_LDFLAGS = $(generic_ldflags) -lstdc++fs
phosphor_bmc_state_manager_CXXFLAGS = $(generic_cxxflags)
phosphor_bmc_state_manager_LDFLAGS = $(generic_ldflags)
OpenPOWER on IntegriCloud