summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2018-10-23 14:59:32 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-26 13:50:23 +0000
commit0570c6940cd193e7106b584984de8fd5f1643bfa (patch)
tree2f8336584eafdfdcdebf4e329247a11f1da043c4 /configure.ac
parent365dee325c14d5b92365895178373c442342bb5c (diff)
downloadphosphor-objmgr-0570c6940cd193e7106b584984de8fd5f1643bfa.tar.gz
phosphor-objmgr-0570c6940cd193e7106b584984de8fd5f1643bfa.zip
Check for boost headers used
The AX_BOOST_BASE macro checks a set of directory locations for the availability of boost which can cause an issue when one is found and its below the specified version. (A version number is required when using the AX_BOOST_BASE macro and was chosen to match the boost version within the SDK.) This fix replaces the use of the AX_BOOST_BASE macro with checking for the boost headers used. Resolves: openbmc/openbmc#3411 Change-Id: Ia24120e55f77576a45f6f85988328f7127ea00c7 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fdb1eed..a22822f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,11 @@ AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find systemd/sd-bus.
# Checks for typedefs, structures, and compiler characteristics.
AX_CXX_COMPILE_STDCXX_17([noext])
AX_APPEND_COMPILE_FLAGS([-fpic -Wall -Werror], [CFLAGS CXXFLAGS])
-AX_BOOST_BASE([1.66],, [AC_MSG_ERROR(["Requires boost."])])
+
+# Checks for boost by the headers used.
+AC_CHECK_HEADER(boost/algorithm/string/predicate.hpp, ,[AC_MSG_ERROR([Could not find boost/algorithm/string/predicate.hpp])])
+AC_CHECK_HEADER(boost/container/flat_map.hpp, ,[AC_MSG_ERROR([Could not find boost/container/flat_map.hpp])])
+AC_CHECK_HEADER(boost/container/flat_set.hpp, ,[AC_MSG_ERROR([Could not find boost/container/flat_set.hpp])])
# Checks for library functions.
LT_INIT([disable-static shared])
OpenPOWER on IntegriCloud