summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2018-03-23 00:22:55 +0530
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-04 16:12:22 +0000
commitbbe4579661b102fa0a5994c9b6a9ecb98add6954 (patch)
tree79067badcce404428106229ea70e3b71b59ddef2 /configure.ac
parentb38401b283d9bc7410b6c6a276cc58ac1a4b33f6 (diff)
downloadphosphor-networkd-bbe4579661b102fa0a5994c9b6a9ecb98add6954.tar.gz
phosphor-networkd-bbe4579661b102fa0a5994c9b6a9ecb98add6954.zip
ncsi: Impelment the setChannel/ClearInterface function
SetChannel:This function will ask underlying NCSI driver to set the package or package/channel combination as the preferred choice. ClearInterface:This function clears any preferred setting from the specific interface. These functions talks with the NCSI driver through the netlink messages. Change-Id: Icb5ae35f83b5b0d0f9654ff4a0dd568fe10680a7 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e902973..bba116d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,13 @@ AM_PROG_AR
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+# Download ncsi.h from github if necessary.
+AC_CHECK_HEADER(linux/ncsi.h,[HAVE_LINUX_NCSI_H=""],[HAVE_LINUX_NCSI_H="-I linux/ncsi.h"])
+AS_IF([test "$HAVE_LINUX_NCSI_H" != ""],
+ AC_MSG_WARN([Could not find linux/ncsi.h: Attempting to download locally for building from https://raw.githubusercontent.com/openbmc/linux/dev-4.13/include/uapi/linux/ncsi.h])
+ AC_SUBST([BT_BMC_DL],[`mkdir -p linux;wget https://raw.githubusercontent.com/openbmc/linux/dev-4.13/include/uapi/linux/ncsi.h -O linux/ncsi.h`])
+)
+
# Suppress the --with-libtool-sysroot error
LT_INIT
OpenPOWER on IntegriCloud