summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOskar Senft <osk@google.com>2018-07-26 16:32:23 -0400
committerosk <osk@google.com>2018-08-13 14:23:32 +0000
commitad21fc2a868122aee973ed5d4f1c652ec2749533 (patch)
tree7c90b1b9d3b775c31eef771bd5257ef6a6045393 /configure.ac
parentd8bad197fb6d7a18c52d19f472676ecae8ec900d (diff)
downloadphosphor-networkd-ad21fc2a868122aee973ed5d4f1c652ec2749533.tar.gz
phosphor-networkd-ad21fc2a868122aee973ed5d4f1c652ec2749533.zip
Add configure option to disable link-local IP address autoconfiguration.
Change-Id: I845ec44a305e91a4880dc1266a3d212db0b4737c Signed-off-by: Oskar Senft <osk@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bba116d..9930889 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,18 @@ AS_IF([test "x$enable_oe_sdk" == "xyes"],
AC_SUBST([OESDK_TESTCASE_FLAGS], [$testcase_flags])
)
+# If set, auto-configure a link-local address on the NIC.
+AC_ARG_ENABLE([link-local-autoconfiguration],
+ AS_HELP_STRING([--disable-link-local-autoconfiguration], [Disable link-local IP address autoconfiguration])
+)
+
+AC_ARG_VAR(LINK_LOCAL_AUTOCONFIGURATION, [Enable link-local address autoconfiguration])
+
+AS_IF([test "x$enable_link_local_autoconfiguration" != "xno"],
+ [LINK_LOCAL_AUTOCONFIGURATION="yes"]
+ AC_DEFINE_UNQUOTED([LINK_LOCAL_AUTOCONFIGURATION], ["$LINK_LOCAL_AUTOCONFIGURATION"], [Enable link-local IP address autoconfiguration])
+)
+
AC_ARG_VAR(DNS_ENTRY_FILE, [File having DNS entries supplied by DHCP])
AS_IF([test "x$DNS_ENTRY_FILE" == "x"], [DNS_ENTRY_FILE="/run/systemd/netif/state"])
AC_DEFINE_UNQUOTED([DNS_ENTRY_FILE], ["$DNS_ENTRY_FILE"], [File having DNS entries supplied by DHCP])
OpenPOWER on IntegriCloud