summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-02-12 19:47:51 -0800
committerWilliam A. Kennington III <wak@google.com>2019-03-12 12:51:58 -0700
commit5f1eb46840818b0b9545ddd2ebd5ac709bb9d57a (patch)
treed5387fcc7dd11492a80a347f36e27b7a6675de81 /configure.ac
parent483e777fd4161ba063ac67a8114429c9b2078352 (diff)
downloadphosphor-networkd-5f1eb46840818b0b9545ddd2ebd5ac709bb9d57a.tar.gz
phosphor-networkd-5f1eb46840818b0b9545ddd2ebd5ac709bb9d57a.zip
configure: Cleanup dbus variables
These are realistically not configurable by the end user and could be provided as a runtime configuration if needed so that custom networkd binaries are not needed for each different busname. Configure variable substitution was kept to ensure the value is consistent between all of the source files. Change-Id: Ic6d50a80b48e2cfc07e48067089236010894e71b Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f8c2ef8..a6cdc3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,13 +105,9 @@ if test "x$enable_link_local_autoconfiguration" = "xyes"; then
AC_DEFINE([LINK_LOCAL_AUTOCONFIGURATION], [1], [Enable link-local IP address autoconfiguration])
fi
-AC_ARG_VAR(BUSNAME_NETWORK, [The Dbus busname to own])
-AS_IF([test "x$BUSNAME_NETWORK" == "x"], [BUSNAME_NETWORK="xyz.openbmc_project.Network"])
-AC_DEFINE_UNQUOTED([BUSNAME_NETWORK], ["$BUSNAME_NETWORK"], [The DBus busname to own])
-
-AC_ARG_VAR(OBJ_NETWORK, [The network manager DBus object path])
-AS_IF([test "x$OBJ_NETWORK" == "x"], [OBJ_NETWORK="/xyz/openbmc_project/network"])
-AC_DEFINE_UNQUOTED([OBJ_NETWORK], ["$OBJ_NETWORK"], [The network manager DBus object path])
+DEFAULT_BUSNAME='xyz.openbmc_project.Network'
+AC_DEFINE_UNQUOTED([DEFAULT_BUSNAME], ["$DEFAULT_BUSNAME"], [The DBus busname to own])
+AC_SUBST(DEFAULT_BUSNAME, ["$DEFAULT_BUSNAME"])
AC_ARG_VAR(SYSTEMD_TARGET, "Target for starting this service")
AS_IF([test "x$SYSTEMD_TARGET" == "x"], [SYSTEMD_TARGET="multi-user.target"])
OpenPOWER on IntegriCloud