summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-06-15 09:07:31 +0530
committerRatan Gupta <ratagupt@in.ibm.com>2017-06-21 15:34:32 +0530
commited123a3a3363144b24c444be5527a3d7b56a72a4 (patch)
tree539b01aa88ff52e55f1e40dbb509450729c9d289 /Makefile.am
parentef85eb9c0e1859f8c420e753341a18ddaa2f8cbb (diff)
downloadphosphor-networkd-ed123a3a3363144b24c444be5527a3d7b56a72a4.tar.gz
phosphor-networkd-ed123a3a3363144b24c444be5527a3d7b56a72a4.zip
Implement the INI config parser
Parse the systemd.network file to get the configuration parameter. Change-Id: Ic9c15a46158d2f1c0948e6eca729663e87051491 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 02ba4c2..6903a75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ noinst_HEADERS = \
types.hpp \
util.hpp \
routing_table.hpp \
+ config_parser.hpp \
system_configuration.hpp
phosphor_network_manager_SOURCES = \
@@ -30,7 +31,8 @@ phosphor_network_manager_SOURCES = \
xyz/openbmc_project/Network/VLAN/Create/server.cpp \
xyz/openbmc_project/Network/IP/Create/server.cpp \
util.cpp \
- routing_table.cpp
+ routing_table.cpp \
+ config_parser.cpp
CLEANFILES = \
xyz/openbmc_project/Network/VLAN/Create/server.cpp \
OpenPOWER on IntegriCloud