summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2018-03-23 00:22:55 +0530
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-04 16:12:22 +0000
commitbbe4579661b102fa0a5994c9b6a9ecb98add6954 (patch)
tree79067badcce404428106229ea70e3b71b59ddef2 /Makefile.am
parentb38401b283d9bc7410b6c6a276cc58ac1a4b33f6 (diff)
downloadphosphor-networkd-bbe4579661b102fa0a5994c9b6a9ecb98add6954.tar.gz
phosphor-networkd-bbe4579661b102fa0a5994c9b6a9ecb98add6954.zip
ncsi: Impelment the setChannel/ClearInterface function
SetChannel:This function will ask underlying NCSI driver to set the package or package/channel combination as the preferred choice. ClearInterface:This function clears any preferred setting from the specific interface. These functions talks with the NCSI driver through the netlink messages. Change-Id: Icb5ae35f83b5b0d0f9654ff4a0dd568fe10680a7 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8696d03..768b5a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,15 @@ noinst_HEADERS = \
ncsi_netlink_SOURCES = \
argument.cpp \
- ncsi_netlink_main.cpp
+ ncsi_netlink_main.cpp \
+ ncsi_util.cpp
+
+ncsi_netlink_LDFLAGS = \
+ $(PHOSPHOR_LOGGING_LIBS) \
+ -lnl-3 \
+ -lnl-genl-3
+
+ncsi_netlink_CPPFLAGS = -isystem=/usr/include/libnl3
phosphor_network_manager_SOURCES = \
OpenPOWER on IntegriCloud