summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-09-03 18:01:22 +0530
committerRatan Gupta <ratagupt@in.ibm.com>2017-09-13 17:06:10 +0530
commit4f80c1a7273a7bfc376d2891d2200022f8b38c50 (patch)
tree1edec10196b3b841df462ade9c3903291b5d6522 /Makefile.am
parent0f9dc1b2c4097b4c54cddfd43bf7f2a24117fec7 (diff)
downloadphosphor-networkd-4f80c1a7273a7bfc376d2891d2200022f8b38c50.tar.gz
phosphor-networkd-4f80c1a7273a7bfc376d2891d2200022f8b38c50.zip
Add the timer class
Usage would be instantiate the timer with the call back and start the timer with the time. callback will be called once the timer expires. Change-Id: I09394264ba18bd90a1c101fc77bc45f7268c5db0 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index aacb465..eac5692 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,8 @@ noinst_HEADERS = \
system_configuration.hpp \
dhcp_configuration.hpp \
vlan_interface.hpp \
- rtnetlink_server.hpp
+ rtnetlink_server.hpp \
+ timer.hpp
phosphor_network_manager_SOURCES = \
ethernet_interface.cpp \
@@ -37,7 +38,8 @@ phosphor_network_manager_SOURCES = \
config_parser.cpp \
dhcp_configuration.cpp \
vlan_interface.cpp \
- rtnetlink_server.cpp
+ rtnetlink_server.cpp \
+ timer.cpp
CLEANFILES = \
xyz/openbmc_project/Network/VLAN/Create/server.cpp \
OpenPOWER on IntegriCloud