summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRatan Gupta <ratagupt@in.ibm.com>2017-05-27 11:47:31 +0530
committerRatan Gupta <ratagupt@in.ibm.com>2017-06-09 07:08:05 +0530
commit233524cbf63a3277960148af672c36929fab09e2 (patch)
tree6ef5a887b6fa6273660183c5a405691c502396c8 /Makefile.am
parent11cef800ad0317b6e9f6f4d9679a847418a36945 (diff)
downloadphosphor-networkd-233524cbf63a3277960148af672c36929fab09e2.tar.gz
phosphor-networkd-233524cbf63a3277960148af672c36929fab09e2.zip
Fetch the kernel routing table
It would be used to get the gateway for a specific network. It would also be used to get the default gateway for the system. Change-Id: I1f7f81e1d6ea6c3f4385f454ad229d4074341c44 Signed-off-by: Ratan Gupta <ratagupt@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ccff0d..370709f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,8 @@ phosphor_network_manager_SOURCES = \
network_manager_main.cpp \
xyz/openbmc_project/Network/VLAN/Create/server.cpp \
xyz/openbmc_project/Network/IP/Create/server.cpp \
- util.cpp
+ util.cpp \
+ routing_table.cpp
CLEANFILES = \
xyz/openbmc_project/Network/VLAN/Create/server.cpp \
@@ -50,8 +51,8 @@ phosphor_network_manager_LDFLAGS = \
phosphor_network_manager_CXXFLAGS = \
$(SYSTEMD_CFLAGS) \
$(SDBUSPLUS_CFLAGS) \
- $(PHOSPHOR_LOGGING_CFLAGS) \
- $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
+ $(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
+ $(PHOSPHOR_LOGGING_CFLAGS)
xyz/openbmc_project/Network/VLAN/Create/server.cpp: xyz/openbmc_project/Network/VLAN/Create.interface.yaml xyz/openbmc_project/Network/VLAN/Create/server.hpp
@mkdir -p `dirname $@`
OpenPOWER on IntegriCloud