summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-08-27 11:12:06 -0700
committerRatan Gupta <ratagupt@linux.vnet.ibm.com>2018-09-05 01:45:02 +0000
commit1f0648d83b1b45f9a44b8c093bfbe9b8e87ed11d (patch)
tree97d5a7f379b17d729ae8711b5588beb10638eb90 /Makefile.am
parenta362922c122045ba5c5c51493812ad9e0e6cdab3 (diff)
downloadphosphor-networkd-1f0648d83b1b45f9a44b8c093bfbe9b8e87ed11d.tar.gz
phosphor-networkd-1f0648d83b1b45f9a44b8c093bfbe9b8e87ed11d.zip
Add -flto to CXXFLAGS
Per openbmc/openbmc#3364, adding -flto to CXX flags in order to reduce overall library and binary sizes. Ref: https://gcc.gnu.org/wiki/LinkTimeOptimization Change-Id: I435596a2e0b134f5220bc9521568354fe9338a79 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b159a76..541afb0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,6 +34,7 @@ ncsi_netlink_LDFLAGS = \
-lnl-genl-3
ncsi_netlink_CPPFLAGS = -isystem=/usr/include/libnl3
+ncsi_netlink_CXXFLAGS = -flto
phosphor_network_manager_SOURCES = \
@@ -78,7 +79,8 @@ phosphor_network_manager_CXXFLAGS = \
$(SYSTEMD_CFLAGS) \
$(SDBUSPLUS_CFLAGS) \
$(PHOSPHOR_DBUS_INTERFACES_CFLAGS) \
- $(PHOSPHOR_LOGGING_CFLAGS)
+ $(PHOSPHOR_LOGGING_CFLAGS) \
+ -flto
xyz/openbmc_project/Network/VLAN/Create/server.cpp: xyz/openbmc_project/Network/VLAN/Create.interface.yaml xyz/openbmc_project/Network/VLAN/Create/server.hpp
@mkdir -p `dirname $@`
OpenPOWER on IntegriCloud