summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorNagaraju Goruganti <ngorugan@in.ibm.com>2018-06-25 23:28:58 -0500
committerNagaraju Goruganti <ngorugan@in.ibm.com>2018-08-08 04:53:31 -0500
commit477b731ad0fd8c116ffcaa8265a508c9fb112479 (patch)
tree6616e76e480d46a0a0f4e1f5d883f9882f16aae9 /test/Makefile.am
parent80aa4762f78f1044d15c918d72316aa388ba0a02 (diff)
downloadphosphor-logging-477b731ad0fd8c116ffcaa8265a508c9fb112479.tar.gz
phosphor-logging-477b731ad0fd8c116ffcaa8265a508c9fb112479.zip
Add unit tests for the phosphor-logging server
-Add unit tests for error wrapping Change-Id: Ib15620d84de8ab5abdc85b8f88dd7c05f83fd6f3 Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c9946d7..68ad467 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -3,7 +3,7 @@ AM_CPPFLAGS = -I${top_srcdir}
TESTS = $(check_PROGRAMS)
check_PROGRAMS = \
- elog_unittest \
+ elog_errorwrap_test \
serialization_test_path \
serialization_test_properties
@@ -19,6 +19,7 @@ test_cxxflags = \
test_ldflags = \
-lgtest_main -lgtest \
+ -lgmock_main -lgmock \
$(PTHREAD_LIBS) \
$(OESDK_TESTCASE_FLAGS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
@@ -35,10 +36,13 @@ test_ldadd = \
$(top_builddir)/elog-process-metadata.o
-elog_unittest_CPPFLAGS = $(test_cppflags)
-elog_unittest_CXXFLAGS = $(test_cxxflags)
-elog_unittest_LDFLAGS = $(test_ldflags)
-elog_unittest_SOURCES = elog_unittest.cpp
+elog_errorwrap_test_CPPFLAGS = $(test_cppflags)
+elog_errorwrap_test_CXXFLAGS = $(test_cxxflags)
+elog_errorwrap_test_SOURCES = elog_errorwrap_test.cpp
+elog_errorwrap_test_LDADD = $(test_ldadd)
+elog_errorwrap_test_LDFLAGS = \
+ $(test_ldflags) \
+ -lstdc++fs
serialization_test_path_CPPFLAGS = $(test_cppflags)
serialization_test_path_CXXFLAGS = $(test_cxxflags)
OpenPOWER on IntegriCloud