summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2016-10-10 12:43:48 -0500
committerAndrew Geissler <andrewg@us.ibm.com>2016-10-31 13:20:30 -0500
commit328889d5a6d0926f4876f3692713a759185812e1 (patch)
tree57b0a6b443e5c2809fbac3094494e6573a85919b /test/Makefile.am
parentf855c3e54f2c06da0649a7dfc31f60d7a36bcd6f (diff)
downloadphosphor-logging-328889d5a6d0926f4876f3692713a759185812e1.tar.gz
phosphor-logging-328889d5a6d0926f4876f3692713a759185812e1.zip
Add in test case which validates elog client interface
Change-Id: I5c5f7a550a8f272251893ff616408c41d32281f9 Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..ee0881b
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,12 @@
+# gtest unit tests which run during a 'make check'
+check_PROGRAMS =
+
+# Run all 'check' test programs
+TESTS = $(check_PROGRAMS)
+
+# Basic test suite for elog interfaces
+check_PROGRAMS += elog_unittest
+elog_unittest_CPPFLAGS = -Igtest $(GTEST_CPPFLAGS)
+elog_unittest_CXXFLAGS = $(PTHREAD_CFLAGS)
+elog_unittest_LDFLAGS = -lgtest_main -lgtest $(PTHREAD_LIBS) $(OESDK_TESTCASE_FLAGS)
+elog_unittest_SOURCES = elog_unittest.cpp \ No newline at end of file
OpenPOWER on IntegriCloud