summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNagaraju Goruganti <ngorugan@in.ibm.com>2017-10-13 08:09:52 -0500
committerNagaraju Goruganti <ngorugan@in.ibm.com>2017-10-24 10:02:36 -0500
commitf8a5a7978355ead2d148c3e93607d1c24adf8a74 (patch)
treef9e0e7a5ce47f8d0192db1505ab846e379af0807 /configure.ac
parentb0562c48b100bd6478d2d3ce5579d4f7bc7ea168 (diff)
downloadphosphor-logging-f8a5a7978355ead2d148c3e93607d1c24adf8a74.tar.gz
phosphor-logging-f8a5a7978355ead2d148c3e93607d1c24adf8a74.zip
Handle more than 100 error logs
Added new Cap for info(and below) severity errors, if cap size reaches, next commited error of severity:info(and below) will replace the first entry of severity:info(and below). Resolves openbmc/openbmc#2381 Change-Id: I2e56c28a934bf3139e57b36d252bd5ad3e1dd90f Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b73f2ca..256cd8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,11 @@ AC_ARG_VAR(ERROR_CAP, [Max number of error entries allowed for commit])
AS_IF([test "x$ERROR_CAP" == "x"], [ERROR_CAP=100])
AC_DEFINE_UNQUOTED([ERROR_CAP], [$ERROR_CAP], [Max number of error entries allowed for commit])
+AC_ARG_VAR(ERROR_INFO_CAP, [Cap on informational (and below) severity errors])
+AS_IF([test "x$ERROR_INFO_CAP" == "x"], [ERROR_INFO_CAP=10])
+AC_DEFINE_UNQUOTED([ERROR_INFO_CAP], [$ERROR_INFO_CAP], \
+ [Cap on informational (and below) severity errors])
+
AC_ARG_VAR(CLASS_VERSION, [Class version to register with Cereal])
AS_IF([test "x$CLASS_VERSION" == "x"], [CLASS_VERSION=1])
AC_DEFINE_UNQUOTED([CLASS_VERSION], [$CLASS_VERSION], [Class version to register with Cereal])
OpenPOWER on IntegriCloud