summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2016-09-29 20:48:08 -0500
committerAndrew Geissler <andrewg@us.ibm.com>2016-10-31 11:51:50 -0500
commitf855c3e54f2c06da0649a7dfc31f60d7a36bcd6f (patch)
tree37e86614d241245fc20eb45027e02b211d957517 /configure.ac
parent91da45310b8ba4d244ec0d9036c9e104d1b9f7c4 (diff)
downloadphosphor-logging-f855c3e54f2c06da0649a7dfc31f60d7a36bcd6f.tar.gz
phosphor-logging-f855c3e54f2c06da0649a7dfc31f60d7a36bcd6f.zip
Error / Event Log Framework
Framework to create an error log entry based on information from the journal log. 1. elog.yaml - User defined reason codes for error scenarios that include description, priority level, and desired metadata fields. 2. elog_parser.py - Parser for the yaml file 3. elog-gen.hpp - Auto-generated file based created by the parser that includes the error log structures. Including for now for ref. 4. elog.hpp - Error log template to create (log a journal log entry with the predefined error log information). Usage: elog<RC>(NAME(value), prev_entry<NAME>()...) where RC - Reason code, NAME - metadata name being logged to a journal entry, prev_entry - A Metadata entry that has previously being logged to a journal entry. Example: log<level::DEBUG>( msg("Info trace to log filename"), entry(file_not_found::file_name::str, my_filename)); elog<file_not_found>(file_not_found::errnum(2), file_not_found::file_path("/tmp/"), prev_entry<file_not_found::file_name>()); Change-Id: Ic51cee80b58e341c071c366c5e2146fd6694012c Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3f01c2e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+AC_PREREQ([2.69])
+AC_INIT([phosphor-logging], [1.0], [https://github.com/openbmc/phosphor-logging/issues])
+
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_PROG_AR()
+AM_SILENT_RULES([yes])
+
+# Checks for programs
+AC_PROG_CXX
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-fpic -Wall -Werror], [CXXFLAGS])
+AC_PROG_INSTALL #Checks/sets the install variable to be used
+AC_PROG_MAKE_SET
+
+# Surpress the --with-libtool-sysroot error
+LT_INIT
+
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
+
+AC_CHECK_HEADER(systemd/sd-journal.h, ,[AC_MSG_ERROR([Could not find \
+systemd/sd-journal.h...systemd developement package required])])
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT \ No newline at end of file
OpenPOWER on IntegriCloud