summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2019-07-10 16:54:13 -0500
committerMatt Spinler <spinler@us.ibm.com>2019-07-26 13:43:04 -0500
commitdf13bdb6e1423b25e7b737f4bf431af3d5c08d8b (patch)
treef8b9d42b3c78d018e83a5b3fcb4014e57d690281 /configure.ac
parent03c1d91559b3e9625d21ad96f93e2d8376cfa1d4 (diff)
downloadphosphor-logging-df13bdb6e1423b25e7b737f4bf431af3d5c08d8b.tar.gz
phosphor-logging-df13bdb6e1423b25e7b737f4bf431af3d5c08d8b.zip
PEL: Add function to generate unique PEL IDs
Create generatePELID() to return a unique 4B PEL ID every time it is called. It will start at a base value, and then increment by 1 each time. It uses a file to save the next value to use. This will be used by the PEL handling code to create unique values for the error log ID field in the Private Header section. Signed-off-by: Matt Spinler <spinler@us.ibm.com> Change-Id: I841a8dcc5dc48e2b663004be3dccfb114ba366f2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27175a5..ead0a07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,13 @@ AC_DEFINE(SYSTEMD_INTERFACE, "org.freedesktop.systemd1.Manager", [systemd interf
AC_ARG_ENABLE([openpower-pel-extension],
AS_HELP_STRING([--enable-openpower-pel-extension], [Create PELs])
)
+
+AC_ARG_VAR(EXTENSION_PERSIST_DIR, [Base directory for extension persistent data])
+AS_IF([test "x$EXTENSION_PERSIST_DIR" == "x"], \
+ [EXTENSION_PERSIST_DIR="/var/lib/phosphor-logging/extensions"])
+AC_DEFINE_UNQUOTED([EXTENSION_PERSIST_DIR], ["$EXTENSION_PERSIST_DIR"], \
+ [Base directory for extension persistent data])
+
AM_CONDITIONAL([ENABLE_PEL_EXTENSION], [test "x$enable_openpower_pel_extension" == "xyes"])
AC_CONFIG_HEADERS([config.h])
OpenPOWER on IntegriCloud