summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2020-01-10 13:49:22 -0600
committerMatt Spinler <spinler@us.ibm.com>2020-01-22 16:26:01 +0000
commitacb7c106a0ded9b9ef96e3c39ce573c919fb9425 (patch)
tree59bd4712440012f3dc2ae3d5c962825e9fdeae6d /configure.ac
parentebffe1c2fbfc93626624f0a0f87f71b6918c76ce (diff)
downloadphosphor-logging-acb7c106a0ded9b9ef96e3c39ce573c919fb9425.tar.gz
phosphor-logging-acb7c106a0ded9b9ef96e3c39ce573c919fb9425.zip
PEL: Print the JSON formatted UserData
Override the getJSON() function in the UserData section so it will support peltool pretty printing when the data has been stored as JSON (component phosphor-logging, subtype 1 as defined in user_data_formats.hpp). It first converts the original JSON string to a nlohmann::json object to validate it is valid JSON and then uses nlohmann::json's stream << operator to convert it into a pretty string. This also sets up a framework where other UserData parsing functions can be called from, and it is all only compiled into peltool, and not into phosphor-log-manager. The UserData section created out of the OpenBMC event log's AdditionalData property already makes use of this format. Here are some example outputs. Note that the 'Data' key is added by this code for JSON that isn't already an object (dict) to make it one. "User Data": { "OPERATION": "something", "REGISTER_FFDC": "REG1=0x8|REG2=0x9|REG3=0x55", "RETURN_VALUE": "-12", "TIMEOUT_IN_MSEC": "100", "_PID": "993" }, "User Data": { "Data": [ "OPERATION", "REGISTER_FFDC", "RETURN_VALUE", "TIMEOUT_IN_MSEC", "_PID" ] }, "User Data": { "Data": "This is a string" } Signed-off-by: Matt Spinler <spinler@us.ibm.com> Change-Id: I7b034ac24339b5b019db3b57d8e71cb03559363e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5f2d81..f3dee4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,6 +164,10 @@ AS_IF([test "x$enable_openpower_pel_extension" == "xyes"],
nlohmann/json.hpp,
[],
[AC_MSG_ERROR([Could not find nlohmann/json.hpp])]])
+ [AC_CHECK_HEADER(
+ fifo_map.hpp,
+ [],
+ [AC_MSG_ERROR([Could not find fifo_map.hpp])]])
)
AC_CONFIG_HEADERS([config.h])
OpenPOWER on IntegriCloud