summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-02-10 14:21:37 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-02-13 19:15:14 +0000
commit9316b9ac43d704a66591ae5e755599db8acef632 (patch)
tree77b82267e8168aef47423e141bf589d4cc5d7900 /configure.ac
parent8692ac9fba635a27e6f711450f41f518129a7d6e (diff)
downloadphosphor-logging-9316b9ac43d704a66591ae5e755599db8acef632.tar.gz
phosphor-logging-9316b9ac43d704a66591ae5e755599db8acef632.zip
build: Add pkg-config for clients
Provide a pkg-config for clients using our headers. Partially resolves openbmc/openbmc#1106 Change-Id: I185da26a0034b4bb315d2b279c776eea87c14a82 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 01423ed..9f51ec6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,12 +21,13 @@ AM_PATH_PYTHON([2.7], [AC_SUBST([PYTHON], [echo "$PYTHON"])], [AC_MSG_ERROR(
# Surpress the --with-libtool-sysroot error
LT_INIT
-# Check for libraries.
-PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
-PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus],,
- AC_MSG_ERROR(["Requires sdbusplus package."]))
-PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [phosphor-dbus-interfaces],,\
- AC_MSG_ERROR(["Requires phosphor-dbus-interfaces package."]))
+# Checks for libraries.
+AX_PKG_CHECK_MODULES([SYSTEMD], [], [libsystemd >= 221], [], [AC_MSG_ERROR(["systemd required and not found."])])
+
+# sdbusplus is non-private because we have no library to link.
+# If we ever have a library, move this to private.
+AX_PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus], [], [], [AC_MSG_ERROR(["sdbusplus required and not found."])])
+AX_PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [], [phosphor-dbus-interfaces], [], [AC_MSG_ERROR(["phosphor-dbus-interfaces required and not found."])])
AC_CHECK_HEADER(systemd/sd-journal.h, ,[AC_MSG_ERROR([Could not find \
systemd/sd-journal.h...systemd developement package required])])
@@ -63,4 +64,5 @@ AC_DEFINE(OBJ_INTERNAL, "/xyz/openbmc_project/Logging/Internal/Manager", [The pr
AC_DEFINE(OBJ_ENTRY, "/xyz/openbmc_project/Logging/Entry", [The log entry DBus object path.])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile test/Makefile])
+AC_CONFIG_FILES([phosphor-logging.pc])
AC_OUTPUT
OpenPOWER on IntegriCloud