summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2019-12-12 13:53:53 -0600
committerMatt Spinler <spinler@us.ibm.com>2020-01-27 08:25:12 -0600
commit5c350fdfb1a92ebdf33d960cc69ac16413974889 (patch)
tree98ad165aa8007f9cb6376f41f6e0654bfe14d719 /configure.ac
parenta19b6234410703c3b45d30636978e35f07f18394 (diff)
downloadphosphor-logging-5c350fdfb1a92ebdf33d960cc69ac16413974889.tar.gz
phosphor-logging-5c350fdfb1a92ebdf33d960cc69ac16413974889.zip
PEL: Add PLDM command handler
Derive a PLDMInterface class from the HostInterface class to implement sending the 'new file available' PLDM command to notify the host of the ID and size of PELs. The command response is received asynchronously by watching for activity on the MCTP file descriptor that was used for the command. If a response isn't received in 10 seconds, it will be considered a failure. Both on response success and failure the class will call the registered callback function and pass it the result. Signed-off-by: Matt Spinler <spinler@us.ibm.com> Change-Id: Ica00da590628cc81114a48e2831a436dc2115269
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f3dee4a..8481175 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,11 +163,13 @@ AS_IF([test "x$enable_openpower_pel_extension" == "xyes"],
[AC_CHECK_HEADER(
nlohmann/json.hpp,
[],
- [AC_MSG_ERROR([Could not find nlohmann/json.hpp])]])
- [AC_CHECK_HEADER(
+ [AC_MSG_ERROR([Could not find nlohmann/json.hpp])])
+ AC_CHECK_HEADER(
fifo_map.hpp,
[],
- [AC_MSG_ERROR([Could not find fifo_map.hpp])]])
+ [AC_MSG_ERROR([Could not find fifo_map.hpp])])
+
+ AX_PKG_CHECK_MODULES([LIBPLDM], [libpldm])]
)
AC_CONFIG_HEADERS([config.h])
OpenPOWER on IntegriCloud