summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-28 07:32:12 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-29 02:19:17 -0500
commit58f16f7e3a60e05a04e25c0a7e363757b65e72d5 (patch)
tree1b0255169af3aff963e4af1ae7dda789971ba5f4 /configure.ac
parent3064a19493ae9f3205daa6531cf2043245127883 (diff)
downloadphosphor-logging-58f16f7e3a60e05a04e25c0a7e363757b65e72d5.tar.gz
phosphor-logging-58f16f7e3a60e05a04e25c0a7e363757b65e72d5.zip
build: add configure flag for metadata handlers
Error metadata handlers are compiled based on a specific compile flag (-DPROCESS_META), which in turn is set if a configure flag is enabled (--enable-metadata-processing). Change-Id: I77319f38cfd219bb831f9a3ee731441211e7bb9b Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93c3526..7055888 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,12 @@ AC_ARG_VAR(CALLOUTS_YAML, [YAML filepath containing generated callouts.])
AS_IF([test "x$CALLOUTS_YAML" == "x"], \
[CALLOUTS_YAML="callouts-example.yaml"])
+# Compile error metadata handlers if we're asked to do so.
+AC_ARG_ENABLE([metadata-processing],
+ AS_HELP_STRING([--enable-metadata-processing], [Compile metadata handlers]),
+ [AX_APPEND_COMPILE_FLAGS([-DPROCESS_META], [CXXFLAGS])]
+)
+
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile test/Makefile])
AC_CONFIG_FILES([phosphor-logging.pc])
OpenPOWER on IntegriCloud