summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNagaraju Goruganti <ngorugan@in.ibm.com>2018-06-25 23:28:58 -0500
committerNagaraju Goruganti <ngorugan@in.ibm.com>2018-08-08 04:53:31 -0500
commit477b731ad0fd8c116ffcaa8265a508c9fb112479 (patch)
tree6616e76e480d46a0a0f4e1f5d883f9882f16aae9 /configure.ac
parent80aa4762f78f1044d15c918d72316aa388ba0a02 (diff)
downloadphosphor-logging-477b731ad0fd8c116ffcaa8265a508c9fb112479.tar.gz
phosphor-logging-477b731ad0fd8c116ffcaa8265a508c9fb112479.zip
Add unit tests for the phosphor-logging server
-Add unit tests for error wrapping Change-Id: Ib15620d84de8ab5abdc85b8f88dd7c05f83fd6f3 Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d9c022d..3ae2407 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,11 +89,15 @@ AC_ARG_VAR(CALLOUTS_YAML, [YAML filepath containing generated callouts.])
AS_IF([test "x$CALLOUTS_YAML" == "x"], \
[CALLOUTS_YAML="callouts-example.yaml"])
-AC_ARG_VAR(ERRLOG_PERSIST_PATH, [Path of directory housing persisted errors.])
-AS_IF([test "x$ERRLOG_PERSIST_PATH" == "x"], \
- [ERRLOG_PERSIST_PATH="/var/lib/phosphor-logging/errors"])
-AC_DEFINE_UNQUOTED([ERRLOG_PERSIST_PATH], ["$ERRLOG_PERSIST_PATH"], \
- [Path of directory housing persisted errors])
+AC_ARG_VAR(ERRLOG_PERSIST_PATH, [Path of directory housing persisted errors.])\
+AS_IF([test "x$ERRLOG_PERSIST_PATH" == "x"],
+ AS_IF([test "x$enable_oe_sdk" == "xyes"], \
+ [ERRLOG_PERSIST_PATH="/tmp/errors"])
+ AS_IF([test "x$enable_oe_sdk" == "x"], \
+ [ERRLOG_PERSIST_PATH="/var/lib/phosphor-logging/errors"])
+ AC_DEFINE_UNQUOTED([ERRLOG_PERSIST_PATH], ["$ERRLOG_PERSIST_PATH"], \
+ [Path of directory housing persisted errors])
+)
# Compile error metadata handlers if we're asked to do so.
AC_ARG_ENABLE([metadata-processing],
OpenPOWER on IntegriCloud