summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-02-13 22:51:40 -0600
committerAdriana Kobylak <anoo@us.ibm.com>2017-02-27 08:49:06 -0600
commit1a7508bbfd10ab9b97cfff757e57a88b7a34c576 (patch)
tree0e97cae480c5f4f828ee19db1b3ef201d62b0413 /configure.ac
parent23b475a04b61ce1b25dc3ca9c0db04fdfdd415e3 (diff)
downloadphosphor-logging-1a7508bbfd10ab9b97cfff757e57a88b7a34c576.tar.gz
phosphor-logging-1a7508bbfd10ab9b97cfff757e57a88b7a34c576.zip
Manager: Auto-generate the code
Auto-generate the Manager code during build time using the sdbus++ tool. Closes: openbmc/phosphor-logging#1 Change-Id: Idb66725dc2b3a919981dc1a0acfebfde16c4420f Signed-off-by: Adriana Kobylak <anoo@linux.vnet.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3c6caca..c99fc1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,8 @@ AC_PROG_CXX
AM_PROG_AR
AC_PROG_INSTALL #Checks/sets the install variable to be used
AC_PROG_MAKE_SET
+AC_PROG_MKDIR_P
+AC_CHECK_PROG([DIRNAME], dirname, dirname)
# Python
AM_PATH_PYTHON([2.7], [AC_SUBST([PYTHON], [echo "$PYTHON"])], [AC_MSG_ERROR(
[Could not find python-2.7 installed...python-2.7 is required])])
@@ -29,12 +31,10 @@ AX_PKG_CHECK_MODULES([SYSTEMD], [], [libsystemd >= 221], [], [AC_MSG_ERROR(["sys
AX_PKG_CHECK_MODULES([SDBUSPLUS], [sdbusplus], [], [], [AC_MSG_ERROR(["sdbusplus required and not found."])])
AX_PKG_CHECK_MODULES([PHOSPHOR_DBUS_INTERFACES], [], [phosphor-dbus-interfaces], [], [AC_MSG_ERROR(["phosphor-dbus-interfaces required and not found."])])
-AC_CHECK_HEADER(systemd/sd-journal.h, ,[AC_MSG_ERROR([Could not find \
-systemd/sd-journal.h...systemd developement package required])])
-AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find \
-systemd/sd-bus.h...systemd developement package required])])
-AC_CHECK_HEADER(sdbusplus/server.hpp, ,[AC_MSG_ERROR([Could not find \
-sdbusplus/server.hpp...openbmc/sdbusplus package required])])
+# Check for sdbus++
+AC_PATH_PROG([SDBUSPLUSPLUS], [sdbus++])
+AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
+ AC_MSG_ERROR(["Requires sdbus++"]))
# Check/set gtest specific functions.
AX_PTHREAD([GTEST_CPPFLAGS="-DGTEST_HAS_PTHREAD=1"],[GTEST_CPPFLAGS="-DGTEST_HAS_PTHREAD=0"])
OpenPOWER on IntegriCloud