summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2017-09-20 04:17:58 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-10-11 17:14:08 +0000
commitdd50846bed41a8f8c3197df3d863ed502279a426 (patch)
tree6f5dc69dd72c327df1487bef80f5a8f3db47e82a /Makefile.am
parent37af9bacea7847f8990a93fc600fad19b3194751 (diff)
downloadphosphor-logging-dd50846bed41a8f8c3197df3d863ed502279a426.tar.gz
phosphor-logging-dd50846bed41a8f8c3197df3d863ed502279a426.zip
Install elog parser and mako script for native processing
Installed elog parser and mako scripts are used by repositories to build elog-errors.hpp for local application specific errors Change-Id: I2353185d28db59b052d2167d6f37f1b385978bb3 Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e2106e..dad2319 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+# For target build
+if !INSTALL_SCRIPTS
# export these headers
nobase_include_HEADERS = \
phosphor-logging/log.hpp \
@@ -108,3 +110,11 @@ pkgconfiglibdir = ${libdir}/pkgconfig
pkgconfiglib_DATA = phosphor-logging.pc
SUBDIRS = test
+else
+# For native build
+# Export elog-gen parser and mako script
+elogdir = ${datadir}/phosphor-logging/elog
+nobase_elog_DATA = \
+ tools/elog-gen.py \
+ tools/phosphor-logging/templates/elog-gen-template.mako.hpp
+endif
OpenPOWER on IntegriCloud