summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-02-15 13:44:16 -0600
committerAdriana Kobylak <anoo@linux.vnet.ibm.com>2017-02-16 15:53:08 -0600
commitc20dae8656898888505df589c32e9f672e03c648 (patch)
tree3a9f8bb03767471fc5c01fbfcc3b3f6468e82d73 /Makefile.am
parent5933433652e6f557503b1c8617f71e84340767c0 (diff)
downloadphosphor-logging-c20dae8656898888505df589c32e9f672e03c648.tar.gz
phosphor-logging-c20dae8656898888505df589c32e9f672e03c648.zip
Create libphosphor-logging library
The commit function would be too big to hold on the header file. Move it to a library and update the phosphos-logging.pc file for users to link against it. Add dependency to libsdbusplus as the commit interface would make use of the transaction id support. Change-Id: I237b15e35a633f1da9bf3401b5bf754154f132db Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fa066a1..1e9d331 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,18 @@ include_HEADERS = log.hpp elog.hpp elog-errors-HostEvent.hpp
# Generate this header, don't export in a distro
nodist_include_HEADERS = elog-gen.hpp
+libphosphor_logging_FILES = \
+ elog.cpp
+libphosphor_loggingdir = ${libdir}
+libphosphor_logging_LTLIBRARIES = libphosphor_logging.la
+libphosphor_logging_la_SOURCES = $(libphosphor_logging_FILES)
+libphosphor_logging_la_LDFLAGS = \
+ $(SYSTEMD_LIBS) \
+ $(SDBUSPLUS_LIBS) \
+ -version-info 1:0:0 -shared
+libphosphor_logging_la_CXXFLAGS = \
+ $(SDBUSPLUS_CFLAGS)
+
# Application test which runs in obmc env (qemu, real hardware)
bin_PROGRAMS = logging-test
logging_test_SOURCES = logging_test.cpp
OpenPOWER on IntegriCloud