summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2017-01-24 12:30:15 -0600
committerAdriana Kobylak <anoo@us.ibm.com>2017-01-30 12:57:25 -0600
commit88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0 (patch)
tree9d3a907abd251debf41c1af553c69badb67e34b5 /Makefile.am
parent7298dc2320ff8b18b16acfb66a06c328c786dd87 (diff)
downloadphosphor-logging-88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0.tar.gz
phosphor-logging-88d7cf8da4a7213e4f91d3eca35ec6a2fd8f9ca0.zip
logging: Create Entry dbus interface
Implement the generated code to create an error/event entry dbus object. Change-Id: I881636fe3e8de680d9a15fff1fe933d5e22eed06 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8487a74..479c086 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,10 +9,13 @@ bin_PROGRAMS = logging-test
logging_test_SOURCES = logging_test.cpp
sbin_PROGRAMS = phosphor-log-manager
+
phosphor_log_manager_SOURCES = \
xyz.openbmc_project.Logging.Internal.Manager.cpp \
log_manager.cpp \
- log_manager_main.cpp
+ log_manager_main.cpp \
+ xyz.openbmc_project.Logging.Entry.cpp \
+ elog_entry.cpp
# Be sure to build needed files before compiling
BUILT_SOURCES = elog-gen.hpp elog-lookup.cpp
OpenPOWER on IntegriCloud