summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-06 05:26:53 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-03-15 21:11:40 +0000
commit682326a19c45b68299cb295b69754a9eb3154f48 (patch)
tree290c9a57b7e250198deb4001ef15bb12bb6a4ac0 /Makefile.am
parentd703881db4ceeb2bae0fee5952bf95da97aed431 (diff)
downloadphosphor-logging-682326a19c45b68299cb295b69754a9eb3154f48.tar.gz
phosphor-logging-682326a19c45b68299cb295b69754a9eb3154f48.zip
callouts: implement metadata handler
Implement handler of the metadata CALLOUT_DEVICE_PATH. This handler will convert a device path to an inventory path and call out the latter. Change-Id: Icbf9c841884ec139f35ea2ac94648e355b421bb2 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c9aa9f8..6ca02d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ nobase_nodist_include_HEADERS = \
xyz/openbmc_project/Logging/Internal/Manager/server.hpp
libphosphor_logging_FILES = \
- elog.cpp
+ elog.cpp elog_meta.cpp
libphosphor_loggingdir = ${libdir}
libphosphor_logging_LTLIBRARIES = libphosphor_logging.la
libphosphor_logging_la_SOURCES = $(libphosphor_logging_FILES)
@@ -35,7 +35,8 @@ phosphor_log_manager_SOURCES = \
elog-lookup.cpp \
elog_entry.cpp \
org.openbmc.Associations.cpp \
- elog-process-metadata.cpp
+ elog-process-metadata.cpp \
+ elog_meta.cpp
# Be sure to build needed files before compiling
BUILT_SOURCES = \
OpenPOWER on IntegriCloud