summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index eb95144..ce83bac 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -9,6 +9,12 @@ noinst_LTLIBRARIES = libtest.la
TESTS = ${check_PROGRAMS}
+types_test_SOURCES = types_test.cpp
+types_test_CFLAGS = ${GTEST_CFLAGS} ${GMOCK_CFLAGS}
+types_test_LDADD = ${GTEST_LIBS} ${GMOCK_LIBS}
+types_test_LDFLAGS = ${OESDK_TESTCASE_FLAGS}
+check_PROGRAMS += types-test
+
extra_yamldir=$(top_srcdir)/example/extra_interfaces.d
phosphor_inventory_test_SOURCES = test.cpp
OpenPOWER on IntegriCloud