summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-08-05 13:09:54 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-08-23 22:35:03 -0500
commit6620e98de4b81e5eadb96cb739b76c8c030418c8 (patch)
tree5df4a58e4e51d04185eef996a34aa59acc4307cf /configure.ac
parentf7b0399a47e6bc0b03843a7b49445cf8ec675e94 (diff)
downloadphosphor-inventory-manager-6620e98de4b81e5eadb96cb739b76c8c030418c8.tar.gz
phosphor-inventory-manager-6620e98de4b81e5eadb96cb739b76c8c030418c8.zip
inventory: implement serialization
Use Cereal to serialize and persist inventory items to the filesystem. Serialize inventory objects as and when they're created/updated via the notify() API. Create a template API to perform serialization on the sdbusplus inventory interface type. An inventory item path /foo/bar/baz implementing interfaces iface1 and iface2 would be stored in paths /foo/bar/baz/iface1 and /foo/bar/baz/iface2. Change-Id: I9a175185eac1740d6f2ca86a3ee13457edfc8ea9 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2746d71..27a6082 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,12 @@ AC_DEFINE_UNQUOTED([BUSNAME], ["$BUSNAME"], [The DBus busname to own.])
AC_DEFINE_UNQUOTED([INVENTORY_ROOT], ["$INVENTORY_ROOT"], [The DBus inventory namespace root.])
AC_DEFINE_UNQUOTED([IFACE], ["$IFACE"], [The manager DBus interface.])
+AC_ARG_VAR(PIM_PERSIST_PATH, [Path of directory housing persisted inventory.])
+AS_IF([test "x$PIM_PERSIST_PATH" == "x"], \
+ [PIM_PERSIST_PATH="/var/lib/phosphor-inventory-manager"])
+AC_DEFINE_UNQUOTED([PIM_PERSIST_PATH], ["$PIM_PERSIST_PATH"], \
+ [Path of directory housing persisted inventory])
+
# Create configured output
AC_CONFIG_FILES([Makefile.extra],
[${srcdir}/generate_makefile.sh $yaml > Makefile.extra],
OpenPOWER on IntegriCloud