summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-10-19 11:54:14 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-11-08 14:43:56 -0500
commit49aefb3176d0a4c6d60ece4884d3850bcf9f75ca (patch)
treeb27c6be4d3cca5d494acad86977166f5488ff852 /configure.ac
parentbf066a6396771214b2a9c47444b991f2750c0cfc (diff)
downloadphosphor-inventory-manager-49aefb3176d0a4c6d60ece4884d3850bcf9f75ca.tar.gz
phosphor-inventory-manager-49aefb3176d0a4c6d60ece4884d3850bcf9f75ca.zip
Add manager skeleton
Add stubbed Notify implementation and register for generated signal callbacks. Add a unit test; which, at this point does little more than verify we don't coredump on startup. Change-Id: I0cda71935947c0d082612a5c52e2b7eba98516ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4496633..936bdec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,13 @@ AM_PROG_AR
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+# Checks for libraries.
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221])
+
+# Checks for header files.
+AC_CHECK_HEADER(systemd/sd-bus.h, ,[AC_MSG_ERROR([Could not find systemd/sd-bus.h...systemd developement package required])])
+AC_CHECK_HEADER(sdbusplus/server.hpp, ,[AC_MSG_ERROR([Could not find sdbusplus/server.hpp...sdbusplus developement package required])])
+
# Checks for typedefs, structures, and compiler characteristics.
AX_CXX_COMPILE_STDCXX_14([noext])
AX_APPEND_COMPILE_FLAGS([-fpic -Wall -Werror], [CXXFLAGS])
@@ -18,6 +25,16 @@ AX_APPEND_COMPILE_FLAGS([-fpic -Wall -Werror], [CXXFLAGS])
# Checks for library functions.
LT_INIT # Removes 'unrecognized options: --with-libtool-sysroot'
+AC_ARG_VAR(BUSNAME, [The DBus busname to own.])
+AC_ARG_VAR(INVENTORY_ROOT, [The DBus inventory namespace root.])
+AC_ARG_VAR(IFACE, [The manager DBus interface.])
+AS_IF([test "x$BUSNAME" == "x"], [BUSNAME="xyz.openbmc_project.Inventory.Manager"])
+AS_IF([test "x$INVENTORY_ROOT" == "x"], [INVENTORY_ROOT="/xyz/openbmc_project/Inventory"])
+AS_IF([test "x$IFACE" == "x"], [IFACE="xyz.openbmc_project.Inventory.Manager"])
+AC_DEFINE_UNQUOTED([BUSNAME], ["$BUSNAME"], [The DBus busname to own.])
+AC_DEFINE_UNQUOTED([INVENTORY_ROOT], ["$INVENTORY_ROOT"], [The DBus inventory namespace root.])
+AC_DEFINE_UNQUOTED([IFACE], ["$IFACE"], [The manager DBus interface.])
+
# Create configured output
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile test/Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud