summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-06 22:55:51 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-08 14:18:05 -0500
commitef2325d4633a7f7a2863a1c9e0fe20178ae7f24b (patch)
tree6382642c066a26c29de87a4407783de802eea01a /Makefile.am
parent3ea767d8945796a30fbe59c47d257e4e6d641458 (diff)
downloadphosphor-inventory-manager-ef2325d4633a7f7a2863a1c9e0fe20178ae7f24b.tar.gz
phosphor-inventory-manager-ef2325d4633a7f7a2863a1c9e0fe20178ae7f24b.zip
Build: Autotools usage improvements
Define CXXFLAGS rather than CFLAGS. Add libraries via LIBADD rather than LDFLAGS. This allows --as-needed to drop unnecessary libs if present. Don't bother with PIC objects for convenience library. Change-Id: I8e09a79a69b35be702811b594fed506332a23c43 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index b6871d0..a78f45e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,10 +8,10 @@ noinst_LTLIBRARIES = libmanagercommon.la libmanager.la
extra_yamldir=$(YAML_PATH)/extra_interfaces.d
phosphor_inventory_SOURCES = app.cpp
-phosphor_inventory_LDADD = libmanager.la
-phosphor_inventory_LDFLAGS = $(SDBUSPLUS_LIBS)
-phosphor_inventory_CFLAGS = $(SDBUSPLUS_CFLAGS)
+phosphor_inventory_LDADD = libmanager.la $(SDBUSPLUS_LIBS)
+phosphor_inventory_CXXFLAGS = $(SDBUSPLUS_CFLAGS)
+libmanagercommon_la_LDFLAGS = -static
libmanagercommon_la_SOURCES = \
errors.cpp \
functor.cpp \
@@ -20,11 +20,12 @@ libmanagercommon_la_LIBADD = \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
$(PHOSPHOR_LOGGING_LIBS)
-libmanagercommon_la_CFLAGS = \
+libmanagercommon_la_CXXFLAGS = \
$(SDBUSPLUS_CFLAGS) \
$(PHOSPHOR_DBUS_INTERACES_CFLAGS) \
$(PHOSPHOR_LOGGING_CFLAGS)
+libmanager_la_LDFLAGS = -static
libmanager_la_SOURCES = \
extra_ifaces.cpp \
generated.cpp
OpenPOWER on IntegriCloud