summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-08-05 13:09:54 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-08-23 22:35:03 -0500
commit6620e98de4b81e5eadb96cb739b76c8c030418c8 (patch)
tree5df4a58e4e51d04185eef996a34aa59acc4307cf /Makefile.am
parentf7b0399a47e6bc0b03843a7b49445cf8ec675e94 (diff)
downloadphosphor-inventory-manager-6620e98de4b81e5eadb96cb739b76c8c030418c8.tar.gz
phosphor-inventory-manager-6620e98de4b81e5eadb96cb739b76c8c030418c8.zip
inventory: implement serialization
Use Cereal to serialize and persist inventory items to the filesystem. Serialize inventory objects as and when they're created/updated via the notify() API. Create a template API to perform serialization on the sdbusplus inventory interface type. An inventory item path /foo/bar/baz implementing interfaces iface1 and iface2 would be stored in paths /foo/bar/baz/iface1 and /foo/bar/baz/iface2. Change-Id: I9a175185eac1740d6f2ca86a3ee13457edfc8ea9 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 769592d..9c44d68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,8 @@ libmanagercommon_la_SOURCES = \
libmanagercommon_la_LIBADD = \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_DBUS_INTERFACES_LIBS) \
- $(PHOSPHOR_LOGGING_LIBS)
+ $(PHOSPHOR_LOGGING_LIBS) \
+ -lstdc++fs
libmanagercommon_la_CXXFLAGS = \
$(SDBUSPLUS_CFLAGS) \
$(PHOSPHOR_DBUS_INTERACES_CFLAGS) \
OpenPOWER on IntegriCloud