summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-10-19 11:54:14 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-11-08 14:43:56 -0500
commit49aefb3176d0a4c6d60ece4884d3850bcf9f75ca (patch)
treeb27c6be4d3cca5d494acad86977166f5488ff852 /Makefile.am
parentbf066a6396771214b2a9c47444b991f2750c0cfc (diff)
downloadphosphor-inventory-manager-49aefb3176d0a4c6d60ece4884d3850bcf9f75ca.tar.gz
phosphor-inventory-manager-49aefb3176d0a4c6d60ece4884d3850bcf9f75ca.zip
Add manager skeleton
Add stubbed Notify implementation and register for generated signal callbacks. Add a unit test; which, at this point does little more than verify we don't coredump on startup. Change-Id: I0cda71935947c0d082612a5c52e2b7eba98516ab Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c1e3c8..9bc1cf2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,10 @@
sbin_PROGRAMS = phosphor-inventory
phosphor_inventory_SOURCES = \
- app.cpp
+ app.cpp \
+ server.cpp \
+ manager.cpp
+phosphor_inventory_LDFLAGS = $(SYSTEMD_LIBS)
+phosphor_inventory_CFLAGS = $(SYSTEMD_CFLAGS)
+
+SUBDIRS = test
OpenPOWER on IntegriCloud