summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2016-10-06 10:15:48 -0500
committerMatthew Barth <msbarth@us.ibm.com>2016-10-13 16:09:09 -0500
commit6292aeed77cb97a069655d80c37d3587d0846bad (patch)
tree79cbaa6fa696f26b79f9ee4615c563d73c0d5f2b /Makefile.am
parent1f1b41ed8e1be794e51559abf14db9dad3e2bcdc (diff)
downloadphosphor-hwmon-6292aeed77cb97a069655d80c37d3587d0846bad.tar.gz
phosphor-hwmon-6292aeed77cb97a069655d80c37d3587d0846bad.zip
Convert build process to autotools
Replaced the use of a manual Makefile with the use of autotools to automatically verify and generate the necessary build files. Follow the steps outlined within the README.md file to build the package. Change-Id: Ieed870c63b2bef83b3741dd22e413c25916ed408 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..571f857
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,12 @@
+bin_PROGRAMS = phosphor-hwmon-readd
+
+phosphor_hwmon_readd_SOURCES = readd.cpp
+phosphor_hwmon_readd_LDADD = libphosphor-hwmon.la
+
+libphosphor_hwmondir = ${libdir}
+libphosphor_hwmon_LTLIBRARIES = libphosphor-hwmon.la
+libphosphor_hwmon_la_SOURCES = \
+ argument.cpp \
+ directory.cpp \
+ sensorset.cpp
+libphosphor_hwmon_la_LDFLAGS = -version-info 0:0:0 -shared
OpenPOWER on IntegriCloud