summaryrefslogtreecommitdiffstats
path: root/user_channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'user_channel/Makefile.am')
-rw-r--r--user_channel/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/user_channel/Makefile.am b/user_channel/Makefile.am
index b9b6ad9..e57f4ad 100644
--- a/user_channel/Makefile.am
+++ b/user_channel/Makefile.am
@@ -10,7 +10,7 @@ COMMON_CXX = \
-DBOOST_SYSTEM_NO_DEPRECATED \
-DBOOST_ALL_NO_LIB
-lib_LTLIBRARIES = libuserlayer.la
+lib_LTLIBRARIES = libuserlayer.la libchannellayer.la
libuserlayer_la_SOURCES = \
user_layer.cpp \
user_mgmt.cpp \
@@ -28,3 +28,15 @@ libuserlayer_la_LDFLAGS = \
libuserlayer_la_CXXFLAGS = \
-I$(top_srcdir) \
$(COMMON_CXX)
+
+libchannellayer_la_SOURCES =
+libchannellayer_la_LDFLAGS = \
+ $(SYSTEMD_LIBS) \
+ $(libmapper_LIBS) \
+ $(PHOSPHOR_LOGGING_LIBS) \
+ $(PHOSPHOR_DBUS_INTERFACES_LIBS) \
+ -lstdc++fs \
+ -version-info 0:0:0 -shared
+libchannellayer_la_CXXFLAGS = \
+ -I$(top_srcdir) \
+ $(COMMON_CXX)
OpenPOWER on IntegriCloud