summaryrefslogtreecommitdiffstats
path: root/libipmid/Makefile.am
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@linux.intel.com>2019-03-20 13:00:20 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-03-20 13:00:20 -0700
commit3719c2fc50d33dbe407eb5351d94252406ccec9e (patch)
treef96d26558e8b56170f4b9ad7059e01be13bd8505 /libipmid/Makefile.am
parentf0bedac613c5cedd2b6560aa84823da0c264017b (diff)
downloadphosphor-host-ipmid-3719c2fc50d33dbe407eb5351d94252406ccec9e.tar.gz
phosphor-host-ipmid-3719c2fc50d33dbe407eb5351d94252406ccec9e.zip
Add generic signal handling API to work with boost::asio
This allows providers or the main application to handle POSIX signals using a callback chain. Each handler can return continueExecution or breakExecution to stop the signal handling chain or allow it to continue. Each handler is registered with a priority and upon reciept of a signal, each handler is executed in priority order until the end of the list is reached or one returns with breakExecution. Change-Id: Idd83625eb1a2d3bdafc92bdd839e0d6386177ff2 Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
Diffstat (limited to 'libipmid/Makefile.am')
-rw-r--r--libipmid/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libipmid/Makefile.am b/libipmid/Makefile.am
index ac35bbf..e4899e1 100644
--- a/libipmid/Makefile.am
+++ b/libipmid/Makefile.am
@@ -13,6 +13,7 @@ pkgconfig_DATA = libipmid.pc
lib_LTLIBRARIES = libipmid.la
libipmid_la_SOURCES = \
sdbus-asio.cpp \
+ signals.cpp \
systemintf-sdbus.cpp
libipmid_la_LDFLAGS = \
$(SYSTEMD_LIBS) \
OpenPOWER on IntegriCloud