summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph@in.ibm.com>2017-05-05 11:20:34 +0530
committerPatrick Williams <patrick@stwcx.xyz>2017-05-19 17:59:19 +0000
commitd5899e7e0c1bfc0b69a9f5bc69267642ad6c038c (patch)
tree9f3c245e33861eb75f9e1a5a4ebd414b0c99224b /configure.ac
parent24676933428fc65bff7370ced39e520efc31b615 (diff)
downloadphosphor-host-ipmid-d5899e7e0c1bfc0b69a9f5bc69267642ad6c038c.tar.gz
phosphor-host-ipmid-d5899e7e0c1bfc0b69a9f5bc69267642ad6c038c.zip
Makefile changes for generating inventory-sensor-gen.cpp
Provide capability for the recipe to pass the config yaml as a configurable output. Fallback to inventory-sensor-example.yaml in case no config yaml is passed. Change-Id: I6a069b0925c3e4c4d56bd1c9767b8fadcdf433b4 Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1134046..4f534df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,10 @@ AS_IF([test "x$SENSOR_YAML_GEN" == "x"], [SENSOR_YAML_GEN="sensor-example.yaml"]
SENSORGEN="$PYTHON ${srcdir}/scripts/sensor_gen.py -i $SENSOR_YAML_GEN"
AC_SUBST(SENSORGEN)
+AS_IF([test "x$INVSENSOR_YAML_GEN" == "x"], [INVSENSOR_YAML_GEN="inventory-sensor-example.yaml"])
+INVSENSORGEN="$PYTHON ${srcdir}/scripts/inventory-sensor.py -i $INVSENSOR_YAML_GEN"
+AC_SUBST(INVSENSORGEN)
+
# Soft Power off related.
AS_IF([test "x$enable_softoff" != "xno"],
# Dbus service name
OpenPOWER on IntegriCloud