summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVernon Mauery <vernon.mauery@linux.intel.com>2019-04-30 11:19:08 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-05-14 15:53:25 +0000
commit5f7ac71048ed04e6f4f2a5ff04f0da8f0722635e (patch)
tree6c0a33fd06bc272fd6069b58f196d036c33ed38f /configure.ac
parent4a8a4eb94df302fdf5cd9854922469185d9e0806 (diff)
downloadphosphor-host-ipmid-5f7ac71048ed04e6f4f2a5ff04f0da8f0722635e.tar.gz
phosphor-host-ipmid-5f7ac71048ed04e6f4f2a5ff04f0da8f0722635e.zip
Fix dependencies on auto-generated code
The sensor/entity/fru/inventory auto-generated cpp code should depend on the mako template, the generator python, and the yaml that it is built with. This modifies the autoconf to export the yaml and the automake to set the dependencies. Tested-by: modify one of the dependencies and watch it get rebuilt Change-Id: Iaab9585c202baf4506e0b7e62aa42a3bf2828ae4 Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2bb011f..8020fbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,20 +103,24 @@ if test -z "$WHITELIST_CONF"; then
WHITELIST_CONF=${srcdir}/host-ipmid-whitelist.conf
fi
-AS_IF([test "x$SENSOR_YAML_GEN" == "x"], [SENSOR_YAML_GEN="sensor-example.yaml"])
+AS_IF([test "x$SENSOR_YAML_GEN" == "x"], [SENSOR_YAML_GEN="scripts/sensor-example.yaml"])
SENSORGEN="$PYTHON ${srcdir}/scripts/sensor_gen.py -i $SENSOR_YAML_GEN"
+AC_SUBST(SENSOR_YAML_GEN)
AC_SUBST(SENSORGEN)
-AS_IF([test "x$INVSENSOR_YAML_GEN" == "x"], [INVSENSOR_YAML_GEN="inventory-sensor-example.yaml"])
+AS_IF([test "x$INVSENSOR_YAML_GEN" == "x"], [INVSENSOR_YAML_GEN="scripts/inventory-sensor-example.yaml"])
INVSENSORGEN="$PYTHON ${srcdir}/scripts/inventory-sensor.py -i $INVSENSOR_YAML_GEN"
+AC_SUBST(INVSENSOR_YAML_GEN)
AC_SUBST(INVSENSORGEN)
-AS_IF([test "x$FRU_YAML_GEN" == "x"], [FRU_YAML_GEN="fru-read-example.yaml"])
+AS_IF([test "x$FRU_YAML_GEN" == "x"], [FRU_YAML_GEN="scripts/fru-read-example.yaml"])
FRUGEN="$PYTHON $srcdir/scripts/fru_gen.py -i $FRU_YAML_GEN"
+AC_SUBST(FRU_YAML_GEN)
AC_SUBST(FRUGEN)
-AS_IF([test "x$ENTITY_YAML_GEN" == "x"], [ENTITY_YAML_GEN="entity-example.yaml"])
+AS_IF([test "x$ENTITY_YAML_GEN" == "x"], [ENTITY_YAML_GEN="scripts/entity-example.yaml"])
ENTITYGEN="$PYTHON $srcdir/scripts/entity_gen.py -i $ENTITY_YAML_GEN"
+AC_SUBST(ENTITY_YAML_GEN)
AC_SUBST(ENTITYGEN)
AC_DEFINE(CALLOUT_FWD_ASSOCIATION, "callout", [The name of the callout's forward association.])
OpenPOWER on IntegriCloud