summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2017-06-04 23:40:16 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-06-26 21:59:43 +0000
commita62bacc534234558f54bf96f368b2b9574f0def1 (patch)
treef7624723fa9c5406ee75daf4c941881043d014ae /Makefile.am
parent8d44b5db8aabd2ed7acac84826931ad9ef68aa32 (diff)
downloadphosphor-host-ipmid-a62bacc534234558f54bf96f368b2b9574f0def1.tar.gz
phosphor-host-ipmid-a62bacc534234558f54bf96f368b2b9574f0def1.zip
generate map of phosphor-dbus fru properties
Reusing frup.hpp, example.yaml, fru-gen.py, writefru.mako.cpp from ipmi-fru-gen repository to generate map of frup properties. Generated map facilitates in reading data from the inventory. Change-Id: I6d6dbc55a340dd06b4639f8bded8cc09df815a59 Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d987cc3..7317cce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,12 @@ sbin_PROGRAMS = \
ipmid_SOURCES = \
ipmid.cpp
nodist_ipmid_SOURCES = ipmiwhitelist.cpp
-BUILT_SOURCES = ipmiwhitelist.cpp sensor-gen.cpp inventory-sensor-gen.cpp
+BUILT_SOURCES = \
+ ipmiwhitelist.cpp \
+ sensor-gen.cpp \
+ inventory-sensor-gen.cpp \
+ fru-read-gen.cpp
+
CLEANFILES = $(BUILT_SOURCES)
#TODO - Make this path a configure option (bitbake parameter)
@@ -24,6 +29,9 @@ sensor-gen.cpp:
inventory-sensor-gen.cpp:
$(AM_V_GEN)@INVSENSORGEN@ -o $(top_builddir) generate-cpp
+fru-read-gen.cpp:
+ $(AM_V_GEN)@FRUGEN@ -o $(top_builddir) generate-cpp
+
libapphandlerdir = ${libdir}/ipmid-providers
libapphandler_LTLIBRARIES = libapphandler.la
libapphandler_la_SOURCES = \
@@ -39,7 +47,8 @@ libapphandler_la_SOURCES = \
groupext.cpp \
sensor-gen.cpp \
utils.cpp \
- inventory-sensor-gen.cpp
+ inventory-sensor-gen.cpp \
+ fru-read-gen.cpp
libapphandler_la_LDFLAGS = $(SYSTEMD_LIBS) $(libmapper_LIBS) $(PHOSPHOR_LOGGING_LIBS) $(PHOSPHOR_DBUS_INTERFACES_LIBS) -lstdc++fs -version-info 0:0:0 -shared
libapphandler_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(libmapper_CFLAGS) $(PHOSPHOR_LOGGING_CFLAGS) $(PHOSPHOR_DBUS_INTERFACES_CFLAGS)
OpenPOWER on IntegriCloud