summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorofery <ofery@goole.com>2019-06-10 16:02:37 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2019-06-18 22:31:04 +0000
commit61d8dcc69736acae379e3e7ed7ecf6a85955db76 (patch)
treec15b97f6834a1517de057a1cc7b4bc9793d45d3d /Makefile.am
parent0b979b61c12ffe6ab8a27acf8ad2a0165d687195 (diff)
downloadphosphor-host-ipmid-61d8dcc69736acae379e3e7ed7ecf6a85955db76.tar.gz
phosphor-host-ipmid-61d8dcc69736acae379e3e7ed7ecf6a85955db76.zip
Add an option to exclude libuserlayer from host-ipmid
Change-Id: I8e14cfd3719c7fbef739f2aa01771bc4321ce290 Signed-off-by: Ofer Yehielli <ofery@google.com> Tested: Enabled the exclude libuserlayer flag in recipes-phosphor/ipmi/phosphor-ipmi-host_%.bbappend +EXTRA_OECONF_append_xxx = " --disable-libuserlayer" +HOSTIPMI_PROVIDER_LIBRARY_remove_xxx = "libusercmds.so" +NETIPMI_PROVIDER_LIBRARY_remove_xxx = "libusercmds.so" Clean build and test that userlayer.so doesn't get included in the build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e7a35a8..dc3e91e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,6 +123,7 @@ libipmi20_la_LDFLAGS = \
-version-info 0:0:0 -shared
libipmi20_la_CXXFLAGS = $(COMMON_CXX)
+if FEATURE_LIBUSERLAYER
providers_LTLIBRARIES += libusercmds.la
libusercmds_la_LIBADD = \
libipmid/libipmid.la \
@@ -135,6 +136,7 @@ libusercmds_la_LDFLAGS = \
$(libmapper_LIBS) \
-version-info 0:0:0 -shared
libusercmds_la_CXXFLAGS = $(COMMON_CXX)
+endif
providers_LTLIBRARIES += libsysintfcmds.la
libsysintfcmds_la_LIBADD = \
OpenPOWER on IntegriCloud