summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2019-04-04 18:00:09 -0700
committerWilliam A. Kennington III <wak@google.com>2019-04-11 18:40:25 -0700
commit5023aa95ff56ea9ebf6a9e265dc4498c38f18bc7 (patch)
tree59636295ba05ae068e78ddb5a3379db68ad9c7d3 /Makefile.am
parent0d49e47978d5f2d0b108b0ddc65943763e88f729 (diff)
downloadphosphor-host-ipmid-5023aa95ff56ea9ebf6a9e265dc4498c38f18bc7.tar.gz
phosphor-host-ipmid-5023aa95ff56ea9ebf6a9e265dc4498c38f18bc7.zip
autotools: Fix for autoconf-archive 2019.01.19
The code coverage macros from the archive changed in a backward incompatible way. This adds a workaround to autodetect either version and do the right thing. Tested: Against the typical, older autotools and the new autotools 2019.01.09 in the CI environment. Change-Id: I765ec46051c2666874dce51675092aa4da989ec5 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5af2544..864eb93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,14 @@ AM_DEFAULT_SOURCE_EXT = .cpp
AM_CPPFLAGS = -I$(abs_srcdir) -I$(abs_srcdir)/include
export AM_CPPFLAGS
+if AUTOCONF_CODE_COVERAGE_2019_01_06
+include $(top_srcdir)/aminclude_static.am
+clean-local: code-coverage-clean
+distclean-local: code-coverage-dist-clean
+else
+@CODE_COVERAGE_RULES@
+endif
+
providersdir = ${libdir}/ipmid-providers
providers_LTLIBRARIES =
@@ -97,8 +105,6 @@ libipmi20_la_SOURCES = \
user_channel/channelcommands.cpp \
$(libipmi20_BUILT_LIST)
-@CODE_COVERAGE_RULES@
-
check_PROGRAMS =
XFAIL_TESTS =
OpenPOWER on IntegriCloud