summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hanson <peterh@google.com>2017-06-07 17:40:45 -0700
committerVernon Mauery <vernon.mauery@linux.intel.com>2018-07-25 17:31:48 +0000
commit4a58985ce0cfb24bc0eb8678a4aa9a0ac42ba524 (patch)
treec267c333630f61e249a1f9fcc4144d8438241d75 /Makefile.am
parent15309efc2c1cebadbabdb0ef5f74a38fb8b78cfd (diff)
downloadphosphor-host-ipmid-4a58985ce0cfb24bc0eb8678a4aa9a0ac42ba524.tar.gz
phosphor-host-ipmid-4a58985ce0cfb24bc0eb8678a4aa9a0ac42ba524.zip
Add OemRouter facility.
OemRouter adds a facility to register OEM Group Message handlers, then dispatch matching messages to the registered handler. Added as a core source so that any dynamic provider can register its messages without requiring any specific load order. Includes code fixes for x86 portability. Change-Id: I47b8fe7873e3c7fdf35a00d3c8a7e17d30c398c4 Signed-off-by: Peter Hanson <peterh@google.com> Signed-off-by: Patrick Venture <venture@google.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ef1bf14..24fd5e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,8 @@ ipmid_SOURCES = \
settings.cpp \
host-cmd-manager.cpp \
timer.cpp \
- utils.cpp
+ utils.cpp \
+ oemrouter.cpp
nodist_ipmid_SOURCES = ipmiwhitelist.cpp
libapphandler_BUILT_LIST = \
@@ -108,7 +109,9 @@ libsysintfcmds_la_CXXFLAGS = $(SYSTEMD_CFLAGS) \
nobase_include_HEADERS = \
host-ipmid/ipmid-api.h \
host-ipmid/ipmid-host-cmd.hpp \
- host-ipmid/ipmid-host-cmd-utils.hpp
+ host-ipmid/ipmid-host-cmd-utils.hpp \
+ host-ipmid/oemopenbmc.hpp \
+ host-ipmid/oemrouter.hpp
# Forcing the build of self and then subdir
SUBDIRS = . test softoff
OpenPOWER on IntegriCloud