summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barth <msbarth@us.ibm.com>2016-07-27 14:50:51 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-09-02 18:37:24 +0000
commit3cff7ed7a9e397de35809f787deabcc8a6b3350d (patch)
treeef53070cd680920f2bd1d984d9bd351e51d229bd /Makefile.am
parentfd28dd7ae4dafc8b919098feb2876623474eeeaa (diff)
downloadphosphor-host-ipmid-3cff7ed7a9e397de35809f787deabcc8a6b3350d.tar.gz
phosphor-host-ipmid-3cff7ed7a9e397de35809f787deabcc8a6b3350d.zip
Convert build process to autotools
Replaced the use of manual Makefile(s) with the use of autotools to automatically verify and generate the necessary build files. Follow the steps outlined within the README file to build the package. Change-Id: Ia3e1e1be7b18fb90382fd56f555866120ae5ece9 Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cbdfa04
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,61 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+
+testit_SOURCES = \
+ ipmisensor.cpp \
+ testit.cpp
+testit_LDFLAGS = $(SYSTEMD_LIBS) $(LIBADD_DLOPEN)
+
+#testaddsel_SOURCES = \
+# testaddsel.cpp \
+# storageaddsel.cpp
+#testaddsel_LDFLAGS = $(SYSTEMD_CFLAGS) $(SYSTEMD_LIBS) $(LIBADD_DLOPEN)
+
+ipmid_SOURCES = \
+ ipmid.cpp
+ ipmiwhitelist.cpp
+nodist_ipmid_SOURCES = ipmiwhitelist.cpp
+BUILT_SOURCES = ipmiwhitelist.cpp
+CLEANFILES = ipmiwhitelist.cpp
+WHITELIST_CONF ?= ${srcdir}/host-ipmid-whitelist.conf
+ipmiwhitelist.cpp: ${srcdir}/generate_whitelist.sh $(WHITELIST_CONF)
+ ${srcdir}/$^ > $@
+#TODO - Make this path a configure option (bitbake parameter)
+ipmid_CPPFLAGS = -DHOST_IPMI_LIB_PATH=\"/usr/lib/host-ipmid/\"
+ipmid_LDFLAGS = $(SYSTEMD_LIBS) $(libmapper_LIBS) $(LIBADD_DLOPEN) -export-dynamic
+
+libapphandlerdir = /usr/lib/host-ipmid
+libapphandler_LTLIBRARIES = libapphandler.la
+libapphandler_la_SOURCES = \
+ apphandler.cpp \
+ sensorhandler.cpp \
+ storagehandler.cpp \
+ chassishandler.cpp \
+ dcmihandler.cpp \
+ ipmisensor.cpp \
+ storageaddsel.cpp \
+ transporthandler.cpp \
+ globalhandler.cpp \
+ groupext.cpp
+libapphandler_la_LDFLAGS = $(SYSTEMD_LIBS) $(libmapper_LIBS) -version-info 0:0:0 -shared
+libapphandler_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(libmapper_CFLAGS)
+
+libhostservicedir = /usr/lib/host-ipmid
+libhostservice_LTLIBRARIES = libhostservice.la
+libhostservice_la_SOURCES = \
+ host-services.c
+libhostservice_la_LDFLAGS = $(SYSTEMD_LIBS) $(libmapper_LIBS) -version-info 0:0:0 -shared
+libhostservice_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(libmapper_CFLAGS)
+
+libdir = /usr/lib/host-ipmid
+includedir = /usr/include/host-ipmid
+
+include_HEADERS = \
+ ipmid-api.h
+
+#default sbin dir
+sbin_PROGRAMS = \
+ ipmid
+
+check_PROGRAMS = \
+ testit
+# testaddsel
OpenPOWER on IntegriCloud