summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2019-08-16 10:50:18 -0700
committerPatrick Venture <venture@google.com>2019-08-20 08:55:01 -0700
commit02e32376817529e960bb918417bb6a55d646a3a3 (patch)
treed3624e105490d5f51dd1df6d762a07d8e1b1a918 /Makefile.am
parent51d0c40ad6c9181a172fb1fc14aa8d39b66e7ba7 (diff)
downloadphosphor-host-ipmid-02e32376817529e960bb918417bb6a55d646a3a3.tar.gz
phosphor-host-ipmid-02e32376817529e960bb918417bb6a55d646a3a3.zip
entitymap: add json parsing support
Add a json parsing method that given an entity map in the format: [ { "id" : 1, "containerEntityId" : 2, "containerEntityInstance" : 3, "isList" : false, "isLinked" : false, "entities" : [ {"id" : 1, "instance" : 2}, {"id" : 1, "instance" : 3}, {"id" : 1, "instance" : 4}, {"id" : 1, "instance" : 5} ] } ] is constructed into the entity map used by sensorhandler. This is meant as part of the transition from the entity map in YAML to JSON. This is step 2. Step 1 moved access to the object behind a method. This adds JSON validation and parsing. Step 3 will add a file path to check and parse. Step 4 will provide a call to parse that file if present and use its data if non-empty. Tested: The method added has not been tested beyond unit-test validation. Signed-off-by: Patrick Venture <venture@google.com> Change-Id: Ic29f022d3812fa9e3af775d542ad055629fd5a01
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dc3e91e..bcac808 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,6 +90,7 @@ libipmi20_la_SOURCES = \
apphandler.cpp \
sys_info_param.cpp \
sensorhandler.cpp \
+ entity_map_json.cpp \
storagehandler.cpp \
chassishandler.cpp \
dcmihandler.cpp \
OpenPOWER on IntegriCloud