summaryrefslogtreecommitdiffstats
path: root/gpio-util/Makefile.am
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-05-25 10:17:13 -0500
committerMatt Spinler <spinler@us.ibm.com>2017-05-25 11:18:49 -0500
commit936a504319e01642fc5803c00ff4aa5baeafacef (patch)
tree43bb5b97599d6bbd8f74b5a7ee4fee4d1eb94a19 /gpio-util/Makefile.am
parent77ec47996d0c8b78d0f08d17fed8ff03107a1e03 (diff)
downloadphosphor-gpio-monitor-936a504319e01642fc5803c00ff4aa5baeafacef.tar.gz
phosphor-gpio-monitor-936a504319e01642fc5803c00ff4aa5baeafacef.zip
Create phosphor-gpio-util framework
This application can write GPIOs. Read support may be added in the future. Aside from just setting a GPIO low or high, it can also do: 0 -> <delay> -> 1 or 1 -> <delay> -> 0. All functionality will be added in future commits Change-Id: I2d3c761eb909ddce3952bfb3173ce271f03544ba Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'gpio-util/Makefile.am')
-rw-r--r--gpio-util/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/gpio-util/Makefile.am b/gpio-util/Makefile.am
new file mode 100644
index 0000000..ea8c763
--- /dev/null
+++ b/gpio-util/Makefile.am
@@ -0,0 +1,8 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+AM_CPPFLAGS = -iquote ${top_srcdir}
+
+sbin_PROGRAMS = \
+ phosphor-gpio-util
+
+phosphor_gpio_util_SOURCES = \
+ main.cpp
OpenPOWER on IntegriCloud