summaryrefslogtreecommitdiffstats
path: root/presence/Makefile.am
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-06-14 16:54:03 -0400
committerPatrick Williams <patrick@stwcx.xyz>2017-08-02 20:18:19 +0000
commitdd62e36eabe275348bc7e74201f960197b01bd0c (patch)
treeca6948e8867d7028df60612b399b624c9f88b46b /presence/Makefile.am
parent221b36b5a84e7e2d7488a6333e3d32982adae9aa (diff)
downloadphosphor-fan-presence-dd62e36eabe275348bc7e74201f960197b01bd0c.tar.gz
phosphor-fan-presence-dd62e36eabe275348bc7e74201f960197b01bd0c.zip
presence: Add new tach sensor implementation
Add a new fan speed (tach) presence implementation for the new PresenceSensor interface. This fan tach sensor behaves mostly like the existing one, with the addition of support for multiple tach sensors for the single PresenceSensor instance, and implementation of the PresenceSensor start and stop interfaces. Change-Id: I535a3e2c78ef0f06f10b6f4cda9a7e2d0e9c11db Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'presence/Makefile.am')
-rw-r--r--presence/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/presence/Makefile.am b/presence/Makefile.am
index e06a135..2ea4929 100644
--- a/presence/Makefile.am
+++ b/presence/Makefile.am
@@ -6,6 +6,7 @@ sbin_PROGRAMS = \
phosphor_fan_presence_tach_SOURCES = \
fan.cpp \
+ tach.cpp \
fan_enclosure.cpp \
tach_sensor.cpp \
tach_detect.cpp
OpenPOWER on IntegriCloud